// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\n\n1. Discover Your Next Adventure: Shop SUVs at Zylker Automobiles.\n2. Ready for the Road Ahead: Explore SUVs at Zylker Automobiles.\n3. Conquer the Road: Find Your Ideal SUV at Zylker Automobiles.\n4. Embark on Your Next Journey: Choose Your SUV at Zylker Automobiles.\n5. Unleash Your Inner Explorer: Find Your Perfect SUV at Zylker Automobiles.").unwrap();
let string = "Don't change this
Do change that
(two newlines) but don't change this
because three newlines follow";
let substitution = " ";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}