import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\n\\n1. Discover Your Next Adventure: Shop SUVs at Zylker Automobiles.\\n2. Ready for the Road Ahead: Explore SUVs at Zylker Automobiles.\\n3. Conquer the Road: Find Your Ideal SUV at Zylker Automobiles.\\n4. Embark on Your Next Journey: Choose Your SUV at Zylker Automobiles.\\n5. Unleash Your Inner Explorer: Find Your Perfect SUV at Zylker Automobiles.";
final String string = "Don't change this\n"
+ "Do change that\n\n"
+ "(two newlines) but don't change this\n\n\n"
+ "because three newlines follow";
final String subst = " ";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}