import Foundation
let pattern = #"\n\n1. Discover Your Next Adventure: Shop SUVs at Zylker Automobiles.\n2. Ready for the Road Ahead: Explore SUVs at Zylker Automobiles.\n3. Conquer the Road: Find Your Ideal SUV at Zylker Automobiles.\n4. Embark on Your Next Journey: Choose Your SUV at Zylker Automobiles.\n5. Unleash Your Inner Explorer: Find Your Perfect SUV at Zylker Automobiles."#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Don't change this
Do change that
(two newlines) but don't change this
because three newlines follow
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #" "#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)