#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\\n\s*(?=\b(?:\d+|A)(?:\.\d+)*\.\B\s*(?:"\s?|“)?\w+)"
Local $sString = "\nA.8. "text" & @CRLF & _
"\n 8.4.2.4.1.2. text" & @CRLF & _
"\n9.1. 12 digit and text" & @CRLF & _
"\n9. text" & @CRLF & _
"\n10.0.1.1. " text" & @CRLF & _
"\n9 text" & @CRLF & _
"\n0.1 Hz" & @CRLF & _
"\n 100. text" & @CRLF & _
"\n 100.5.1. text" & @CRLF & _
"\nA.500 text" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")