import Foundation
let pattern = #"\\n\s*(?=\b(?:\d+|A)(?:\.\d+)*\.\B\s*(?:"\s?|“)?\w+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
\nA.8. "text
\n 8.4.2.4.1.2. text
\n9.1. 12 digit and text
\n9. text
\n10.0.1.1. " text
\n9 text
\n0.1 Hz
\n 100. text
\n 100.5.1. text
\nA.500 text
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)