using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\\n\s*(?=\b(?:\d+|A)(?:\.\d+)*\.\B\s*(?:""\s?|“)?\w+)";
string input = @"\nA.8. ""text
\n 8.4.2.4.1.2. text
\n9.1. 12 digit and text
\n9. text
\n10.0.1.1. "" text
\n9 text
\n0.1 Hz
\n 100. text
\n 100.5.1. text
\nA.500 text
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}