const regex = /\\n\s*(?=\b(?:\d+|A)(?:\.\d+)*\.\B\s*(?:"\s?|“)?\w+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\\\n\\s*(?=\\b(?:\\d+|A)(?:\\.\\d+)*\\.\\B\\s*(?:"\\s?|“)?\\w+)', 'gm')
const str = `\\nA.8. "text
\\n 8.4.2.4.1.2. text
\\n9.1. 12 digit and text
\\n9. text
\\n10.0.1.1. " text
\\n9 text
\\n0.1 Hz
\\n 100. text
\\n 100.5.1. text
\\nA.500 text
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}