use strict;
my $str = '\\nA.8. "text
\\n 8.4.2.4.1.2. text
\\n9.1. 12 digit and text
\\n9. text
\\n10.0.1.1. " text
\\n9 text
\\n0.1 Hz
\\n 100. text
\\n 100.5.1. text
\\nA.500 text
';
my $regex = qr/\\n\s*(?=\b(?:\d+|A)(?:\.\d+)*\.\B\s*(?:"\s?|“)?\w+)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}