#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "((?:A|LO?)(?:\.\s*)?|(?:[DR](?:\s*\.\s*)?(?:\s*\*\s*)?))((?:\d+)(?:(?:\-\d+)*))"
Local $sString = "A101" & @CRLF & _
"A.202" & @CRLF & _
"D*1-2-3" & @CRLF & _
"D. * 4-5-7" & @CRLF & _
"D * 78"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")