// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"((?:A|LO?)(?:\.\s*)?|(?:[DR](?:\s*\.\s*)?(?:\s*\*\s*)?))((?:\d+)(?:(?:\-\d+)*))").unwrap();
let string = "A101
A.202
D*1-2-3
D. * 4-5-7
D * 78";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}