use strict;
my $str = 'A101
A.202
D*1-2-3
D. * 4-5-7
D * 78';
my $regex = qr/((?:A|LO?)(?:\.\s*)?|(?:[DR](?:\s*\.\s*)?(?:\s*\*\s*)?))((?:\d+)(?:(?:\-\d+)*))/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}