const regex = /((?:A|LO?)(?:\.\s*)?|(?:[DR](?:\s*\.\s*)?(?:\s*\*\s*)?))((?:\d+)(?:(?:\-\d+)*))/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((?:A|LO?)(?:\\.\\s*)?|(?:[DR](?:\\s*\\.\\s*)?(?:\\s*\\*\\s*)?))((?:\\d+)(?:(?:\\-\\d+)*))', 'g')
const str = `A101
A.202
D*1-2-3
D. * 4-5-7
D * 78`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}