package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`((?:A|LO?)(?:\.\s*)?|(?:[DR](?:\s*\.\s*)?(?:\s*\*\s*)?))((?:\d+)(?:(?:\-\d+)*))`)
var str = `A101
A.202
D*1-2-3
D. * 4-5-7
D * 78`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}