import Foundation
let pattern = #"((?:A|LO?)(?:\.\s*)?|(?:[DR](?:\s*\.\s*)?(?:\s*\*\s*)?))((?:\d+)(?:(?:\-\d+)*))"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
A101
A.202
D*1-2-3
D. * 4-5-7
D * 78
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)