# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(.+)(\n(\1))*$/$1/gm;t' <<< "AAAAA
AAAAA
AAAAA
BB
BBBBB
BBBBB
CCC
CCC
CCC
111
111
@@@
@@@"