# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(.+)(\n(\1))*$"
test_str = ("AAAAA\n"
"AAAAA\n"
"AAAAA\n"
"BB\n"
"BBBBB\n"
"BBBBB\n"
"CCC\n"
"CCC\n"
"CCC\n"
"111\n"
"111\n"
"@@@\n"
"@@@")
subst = "$1"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.