re = /^(.+)(\n(\1))*$/m
str = 'AAAAA
AAAAA
AAAAA
BB
BBBBB
BBBBB
CCC
CCC
CCC
111
111
@@@
@@@'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result