#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(.+)(\n(\1))*$"
Local $sString = "AAAAA" & @CRLF & _
"AAAAA" & @CRLF & _
"AAAAA" & @CRLF & _
"BB" & @CRLF & _
"BBBBB" & @CRLF & _
"BBBBB" & @CRLF & _
"CCC" & @CRLF & _
"CCC" & @CRLF & _
"CCC" & @CRLF & _
"111" & @CRLF & _
"111" & @CRLF & _
"@@@" & @CRLF & _
"@@@"
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)