const regex = /^(.+)(\n(\1))*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(.+)(\\n(\\1))*$', 'gm')
const str = `AAAAA
AAAAA
AAAAA
BB
BBBBB
BBBBB
CCC
CCC
CCC
111
111
@@@
@@@`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);