const regex = new RegExp(' (?P<dialect>[^+:]+)
(?:
\\+
(?P<driver>[^:]+)
)?
://
(?P<username>[^:@]+)
(?:
:
(?P<password>[^@]+)
)?
@
(?P<host>[^:/]+)
(?:
:
(?P<port>\\S+)
)?
/
(?P<database>.*)
', '')
const str = `dialect+driver://username:password@host:port/database`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}