// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?x) (?P<dialect>[^+:]+)
(?:
\+
(?P<driver>[^:]+)
)?
://
(?P<username>[^:@]+)
(?:
:
(?P<password>[^@]+)
)?
@
(?P<host>[^:/]+)
(?:
:
(?P<port>\S+)
)?
/
(?P<database>.*)
").unwrap();
let string = "dialect+driver://username:password@host:port/database";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}