re = / (?P<dialect>[^+:]+)
(?:
\+
(?P<driver>[^:]+)
)?
:\/\/
(?P<username>[^:@]+)
(?:
:
(?P<password>[^@]+)
)?
@
(?P<host>[^:\/]+)
(?:
:
(?P<port>\S+)
)?
\/
(?P<database>.*)
/x
str = 'dialect+driver://username:password@host:port/database'
# Print the match result
str.match(re) do |match|
puts match.to_s
end