# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\.\B/ /g;t' <<< "['taxes............................. .7 21.4 (6.2)','regulatory and other matters..................$ 39.9 61.5 41.1','Producer contract reformation cost recoveries............................ DASH 26.3 28.3']"