const regex = new RegExp('\\.\\B', 'g')
const str = `['taxes............................. .7 21.4 (6.2)','regulatory and other matters..................\$ 39.9 61.5 41.1','Producer contract reformation cost recoveries............................ DASH 26.3 28.3']`;
const subst = ` `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);