$re = '/\.\B/';
$str = '[\'taxes............................. .7 21.4 (6.2)\',\'regulatory and other matters..................$ 39.9 61.5 41.1\',\'Producer contract reformation cost recoveries............................ DASH 26.3 28.3\']';
$subst = " ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;