using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\.\B";
string substitution = @" ";
string input = @"['taxes............................. .7 21.4 (6.2)','regulatory and other matters..................$ 39.9 61.5 41.1','Producer contract reformation cost recoveries............................ DASH 26.3 28.3']";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}