use strict;
my $str = '[\'taxes............................. .7 21.4 (6.2)\',\'regulatory and other matters..................$ 39.9 61.5 41.1\',\'Producer contract reformation cost recoveries............................ DASH 26.3 28.3\']';
my $regex = qr/\.\B/p;
my $subst = ' ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";