package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\.\B`)
var str = `['taxes............................. .7 21.4 (6.2)','regulatory and other matters..................$ 39.9 61.5 41.1','Producer contract reformation cost recoveries............................ DASH 26.3 28.3']`
var substitution = " "
fmt.Println(re.ReplaceAllString(str, substitution))
}