#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?im)^(\"[^"\/]*\"|[^"\/]*\/?)+$"
Local $sString = ""hello/world" " & @CRLF & _
"hello/world/"How are you"" & @CRLF & _
""test"" & @CRLF & _
"test" & @CRLF & _
"test/""/test" & @CRLF & _
"test"test/"/test/test/"
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)