const regex = /^(\"[^"\/]*\"|[^"\/]*\/?)+$/im;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\"[^"\\\/]*\\"|[^"\\\/]*\\\/?)+$', 'im')
const str = `"hello/world"
hello/world/"How are you"
"test"
test
test/""/test
test"test/"/test/test/`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);