// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?im)^(\"[^"\/]*\"|[^"\/]*\/?)+$"#).unwrap();
let string = "\"hello/world\"
hello/world/\"How are you\"
\"test\"
test
test/\"\"/test
test\"test/\"/test/test/";
let substitution = "$1";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}