use strict;
my $str = '"hello/world"
hello/world/"How are you"
"test"
test
test/""/test
test"test/"/test/test/';
my $regex = qr/^(\"[^"\/]*\"|[^"\/]*\/?)+$/imp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";