using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(\""[^""\/]*\""|[^""\/]*\/?)+$";
string substitution = @"$1";
string input = @"""hello/world""
hello/world/""How are you""
""test""
test
test/""/test
test""test/""/test/test/";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution, 1);
}
}