# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:^|\G)(\d{1,3})(?=(\d{3})+(?:\.\d+)?$)/$1,/gm;t' <<< "1829383839.2937484
1234567890"