import Foundation
let pattern = #"(?:^|\G)(\d{1,3})(?=(\d{3})+(?:\.\d+)?$)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
1829383839.2937484
1234567890
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1,"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)