using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:^|\G)(\d{1,3})(?=(\d{3})+(?:\.\d+)?$)";
string substitution = @"$1,";
string input = @"1829383839.2937484
1234567890";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}