const regex = /(?:^|\G)(\d{1,3})(?=(\d{3})+(?:\.\d+)?$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:^|\\G)(\\d{1,3})(?=(\\d{3})+(?:\\.\\d+)?$)', 'gm')
const str = `1829383839.2937484
1234567890`;
const subst = `$1,`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);