use strict;
my $str = '1829383839.2937484
1234567890';
my $regex = qr/(?:^|\G)(\d{1,3})(?=(\d{3})+(?:\.\d+)?$)/mp;
my $subst = '$1,';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";