using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=[\s>])#(\d*[A-Za-z_]+\d*)\b(?!;)";
string input = @"Here's a #hashtag and here is #not_a_tag; which should be different.
Also testing: Mid#hash. #123 #123 #!@£ and <p>#hash</p>
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}