$re = '/(?<=[\s>])#(\d*[A-Za-z_]+\d*)\b(?!;)/';
$str = 'Here\'s a #hashtag and here is #not_a_tag; which should be different.
Also testing: Mid#hash. #123 #123 #!@£ and <p>#hash</p>
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);