import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=[\\s>])#(\\d*[A-Za-z_]+\\d*)\\b(?!;)";
final String string = "Here's a #hashtag and here is #not_a_tag; which should be different. \n"
+ "Also testing: Mid#hash. #123 #123 #!@£ and <p>#hash</p>\n\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}