re = /(?<=[\s>])#(\d*[A-Za-z_]+\d*)\b(?!;)/
str = 'Here\'s a #hashtag and here is #not_a_tag; which should be different.
Also testing: Mid#hash. #123 #123 #!@£ and <p>#hash</p>
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end