import Foundation
let pattern = ##"(?<=[\s>])#(\d*[A-Za-z_]+\d*)\b(?!;)"##
let regex = try! NSRegularExpression(pattern: pattern)
let testString = ##"""
Here's a #hashtag and here is #not_a_tag; which should be different.
Also testing: Mid#hash. #123 #123 #!@£ and <p>#hash</p>
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)