const regex = /(?<=[\s>])#(\d*[A-Za-z_]+\d*)\b(?!;)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=[\\s>])#(\\d*[A-Za-z_]+\\d*)\\b(?!;)', 'g')
const str = `Here's a #hashtag and here is #not_a_tag; which should be different.
Also testing: Mid#hash. #123 #123 #!@£ and <p>#hash</p>
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}