#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ms)^Name:\s*(.*?)USB Device Filters:"
Local $sString = "Name: Server1 10.0.0.11" & @CRLF & _
"Groups: /" & @CRLF & _
"Guest OS: Ubuntu (64-bit)" & @CRLF & _
"\n" & @CRLF & _
"<none>" & @CRLF & _
"USB Device Filters:" & @CRLF & _
"" & @CRLF & _
"Name: Server2 10.0.0.12" & @CRLF & _
"Groups: /" & @CRLF & _
"Guest OS: Debian (64-bit)" & @CRLF & _
"\n" & @CRLF & _
"<none>" & @CRLF & _
"USB Device Filters:"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")