# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^Name:\s*(.*?)USB Device Filters:"
test_str = ("Name: Server1 10.0.0.11\n"
"Groups: /\n"
"Guest OS: Ubuntu (64-bit)\n"
"\\n\n"
"<none>\n"
"USB Device Filters:\n\n"
"Name: Server2 10.0.0.12\n"
"Groups: /\n"
"Guest OS: Debian (64-bit)\n"
"\\n\n"
"<none>\n"
"USB Device Filters:")
matches = re.finditer(regex, test_str, re.MULTILINE | re.DOTALL)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.