import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^Name:\\s*(.*?)USB Device Filters:";
final String string = "Name: Server1 10.0.0.11\n"
+ "Groups: /\n"
+ "Guest OS: Ubuntu (64-bit)\n"
+ "\\n\n"
+ "<none>\n"
+ "USB Device Filters:\n\n"
+ "Name: Server2 10.0.0.12\n"
+ "Groups: /\n"
+ "Guest OS: Debian (64-bit)\n"
+ "\\n\n"
+ "<none>\n"
+ "USB Device Filters:";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}