$re = '`^Name:\s*(.*?)USB Device Filters:`ms';
$str = 'Name: Server1 10.0.0.11
Groups: /
Guest OS: Ubuntu (64-bit)
\\n
<none>
USB Device Filters:
Name: Server2 10.0.0.12
Groups: /
Guest OS: Debian (64-bit)
\\n
<none>
USB Device Filters:';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);