re = /^Name:\s*(.*?)USB Device Filters:/m
str = 'Name: Server1 10.0.0.11
Groups: /
Guest OS: Ubuntu (64-bit)
\\n
<none>
USB Device Filters:
Name: Server2 10.0.0.12
Groups: /
Guest OS: Debian (64-bit)
\\n
<none>
USB Device Filters:'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end