// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?ms)^Name:\s*(.*?)USB Device Filters:").unwrap();
let string = "Name: Server1 10.0.0.11
Groups: /
Guest OS: Ubuntu (64-bit)
\\n
<none>
USB Device Filters:
Name: Server2 10.0.0.12
Groups: /
Guest OS: Debian (64-bit)
\\n
<none>
USB Device Filters:";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}